Saturday, August 7, 2010

Canon MP Navigator Software Has Stopped Working

If you own a Canon All-in-One printer, you probably have Canon's MP Navigator software installed on your computer. This software is necessary for using the scan features on the printer. 

While MP Navigator is nice software, sometimes it stops working.   Folks running 64-bit versions of Windows 7 or Vista often see the error "MP Navigator has stopped working" when they click the icon to run the program.  And unfortunately, uninstalling and reinstalling the software doesn't seem to fix the problem. 

The other day I was working on a computer that had this problem and after several email exchanges with suggestions from Canon tech support, the problem persisted.   I finally found the answer on a forum and wanted to share the solution here. 

If you see a consistent error message, "MP Navigator has stopped working" you might want to try these steps.  First thing you have to do though, is show your hidden folders.  To do this ...

  1. Click the START button and then CONTROL PANEL
  4. Click VIEW tab
  5. Under Advanced Settings, click "Show hidden files, folders,and drives"
  6. Click OK to exit window
Once the hidden folders are visible, you want to find the file named, "My websites on MSN".  For advanced users, the actual path to the file is:

C:\Users\\App Data\Roaming\Microsoft\Windows\Network Shortcuts\My Web Sites on MSN

For those folks who don't understand how to find a file using the path above, follow the instructions below:
  1. Click the START button and then COMPUTER
  2. Double click the C-Drive
  3. Double click the folder named USERS
  4. Double click your user folder (it may have your name or say HP Administrator on it)
  5. Double click the folder named APPLICATION DATA (App Data)
  6. Double click the folder named ROAMING
  7. Double click the folder named MICROSOFT
  8. Double click the folder named WINDOWS
  9. Double click the folder named NETWORK SHORTCUTS
  10. If you see an icon (or file) named "My MSN Shortcuts", delete it (and confirm deletion)
Once that file is removed, it's a good idea to undo our first set of steps and hide those folders again which are normally hidden. To do this, follow the first set of steps above.  However, when you get to step 5, be sure to check the appropriate option to "not show hidden files, folders and drives".


  1. Well, I couldn't find the icon (file) "My MSN Shortcuts". But I found the shortcut "[username]. in that folder. I deleted it. And: problem solved.

  2. Love your blog because I learned a lot from it and thank you for sharing this because I'm not a techie person and this one really helps me.

  3. Thanks for sharing this fix. It worked for me .. strange how could this affect the software.

  4. This solution worked great after going down quite a few dead ends at the Canon support site. Thank You!!

  5. thank a lot.problem solved..thank you

  6. thanks alot man! really helped me out

  7. Thank you thank you thank you! I can stop beating my head on the wall now. I did not have a file for MSN Shortcuts in there but mine was called Microsoft Websites. I deleted it and the software now opens! Thank you again!

  8. Anyone tell Canon about this fix? I wasted at least an hour working on this with customer service. Their solution was to create a new user profile.

  9. What a great fix, but a very strange one at that.
    Thank you, mine had stopped working after being installed for over a year. I suspect it might have happened after a Microsoft update as the date of modification for that particular file was only 3 weeks ago.

  10. This worked beautifully. I upgraded, uninstalled, reinstalled and nothing worked until I googled the error message and tried this solution. I am going to bookmark this in case it happens again. Kudos to whoever figured this out.

  11. There wasn't anything in my network shortcuts folder. I couldn't delete any files since there wasn't anything in it. I still can't get the scanner to work. I've tried everything at this point. Is there any hope for the MP navigator to start working?

  12. Thank you, thank you, thank you. It worked for me too after much time on the web and doing driver reinstalls.
    The MSN file to delete was found under my Windows 7 directory in a box under the D drive.
    What a wierd fix, I never would have thunk it!

  13. If there is any other solution PLEASE let me know - I got to that folder and it was already empty - I am trawling for solutions but none seem to work.
    It used to work

  14. Another rogue file................based on this and another solution found on the web I searched for a recent msn file (as my MP Navigator stopped working a few days ago). I found this .... when I deleted it my MP navigator worked. THANK YOU for putting me on the right path - and this may help other folk

    The folder name was .........

    C:\Users\(username) \AppData\Roaming\Macromedia\Flash Player\ and when I look at

    I don't know if this will stop something else working - but personally at this stage do not care because I need my navigator more. I suspect this got installed with Pagemaker free version.
    C:\Users\(username)\AppData\Roaming\Macromedia\Flash Player\#SharedObjects\HJKJZMSN

  15. Just one mroe person grateful for you having found and posted this.

    One would hope that Canon would address the issue, but one would be wrong, huh?

  16. Well, done, works a charm, both on Win7 32 and 64. Would never have found that. Very obscure....

  17. Amazing. I have tried so many things, as uninstalling, new drivers and I do know what.
    But this trick really does work.


  18. My Canon 5600f has been giving me blood pressure for the past 2 years, and I am sure that pop up saying "MP Navigator has stopped working had developed a self confident smirk." Now I'm not a religious fundamentalist, just an interested philosopher, but this is yet more evidence to show that the unregulated creative activity of the various big software companies is creating a "Tower of Babel!"

    MP Navigator and Canon are now standing in the corner at the back of the class, where they belong. Thank you for a simple comprehensible explanation in a normal English. Why isn't more computer help delivered in this forma?

  19. Thank you sooo much for taking time to share this solution. You have saved many of us much time and frustration. What a remote file. I could have struggled with this for months and never found your solution. Thanks!!!!!!

  20. Thanks a lot. It helped to me.
    ps. How is it possible that one small file makes realy good software crashes?

  21. I have a variation of this problem with a Canon LiDE 90 and Windows 7 64 bit O/S. About a week ago, Canon MP Navigator stopped working. I could scan one item, save it, but the program would hang in the window headed "MP Navigator EX - CanoScan LiDE 90". I would have a message that displayed "In progress ... Please wait a few moments". The program locks up and never continues.

    I have looked for the presence of the "My websites on MSN" or similar file as described, but found the folder empty. No such file elsewhere.

    I have reinstalled both the driver and MP Navigator from the Canon site several times, but symptoms are unchanged.

    My work-around is to go into Task Manager and kill the process "mpnex10.exe". That lets me scan one more item.

    Any other suggestions?

  22. It works!! Thank you so very much for your comprehensive, easy to follow fix for something I had spent hours on reinstalling drivers and trying to run the program in an older version of Windows and everything else I could think of. Hats off to you!!

  23. Is this a practical joke? I found that file, and deleted it. Of course it didn't solve the problem. Why would it?

  24. If anyone is still having issues, and happens to have MyPCBackup installed, try uninstalling this software.

    None of the other solutions had worked, but uninstalling this backup program make the problem go away